Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

mswyka

Simplicity 7790 Electrical Question

Recommended Posts

mswyka

Our 7790 is a good reliable tractor. Over the winter we would need to charge the battery regularly so that it would start. Last week we bought a new battery. Yesterday I went out to the shed and the battery was dead and under the console there was an occasional metallic "doink" sound - very similar to the throwing of an older style relay. I have the battery charged up but have left the cables off to keep it from going dead again. I am interested in any thoughts of what might be the problem.

Share this post


Link to post
Share on other sites
maxwood

Hello, Check the headlight wiring, it may be close to the muffler. I have seen several with melted wires, there is a plug connector for the headlights near the front of the frame .

Thanks Ken in Mi

Share this post


Link to post
Share on other sites
mswyka

Thank you. I will make sure to check this.

Does anyone have any good ways to check the electrical system with the battery in place? Is my best approach to pull off the top of the dashboard?

Share this post


Link to post
Share on other sites
mswyka

Well, after taking out the battery and the cover of the dash panel the problem was quite obvious - a couple of bare wires. It was not clear to me if it was a rodent or just wear against the steering column. But we now seem to be back in business. Thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who's Online (See full list)

    • Abryant2004
    • Ken7790
    • Brettw
  • Today's Birthdays

    1. 9934059
      9934059
      (72 years old)
  • Recent Status Updates

    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
    • thedaddycat

      thedaddycat  »  SmilinSam

      It's in pretty sad shape, but yes I have a yellow plastic cap that I'm fairly certain is what you need. PM me your details and I'll get it out to you.
      · 0 replies
  • Adverts

×