Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Mike

k341 starting issues

Recommended Posts

Mike

I sold a 916h to my neighbor last year ran sweet till now. good spark, good fuel. won't run even if you put gas in the cylinder, just get a backfire. I'm guessing a valve issue or crank timing, can you sheer a key on kohlers?

Neighbor told me when it quit, it started sputtering and lost about 1/2 power then died. In the past if that happened I cleaned the points and that fixed it. This also happened after running fuel dry when hot.

Thanks for any insights

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • DTS
    • macallis180
    • marksr
    • PGL
  • Today's Birthdays

    1. rokon2813
      rokon2813
      (56 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×