Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Tarheel

Sluggish Sunstrand

Recommended Posts

Tarheel

I have an Agco BGB tractor from the last year they were made. The hydro seems to be getting more and more sluggish as time passes.

It is hard to describe j8ust what its doing. It is like there is a delay at times between moving the control and the response. Now it is getting slow pulling a hill. I have other units I can bolt on it but would like to figure out what is going on with this one.

Thanks for any input.

Share this post


Link to post
Share on other sites
yukon

lubricate the linkage to make sure its not binding anywhere next check the plastic roller on the top of the hydro unit at the end of your linkage to see if its worn next check to see if your low on fluid its hard to tell on a sunstrand. hope this helps.

Share this post


Link to post
Share on other sites
B-16_IC

I would follow yukon's suggestions. Does it speed up going downhill? I have had them be sluggish like you described and then speed up going downhill, it was the nylon roller hanging up.

Share this post


Link to post
Share on other sites
Tarheel

I changed the filter and filled with fluid. Heading out to mow now if the storms don't stop me. I'll lube everything and see what happens.

Yes it does speed up going down hill, But not like the old Vickers which seemed to free wheel.

Thanks for the input.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • Abryant2004
    • Ken7790
    • plastikosmd
    • Brettw
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
    • thedaddycat

      thedaddycat  »  SmilinSam

      It's in pretty sad shape, but yes I have a yellow plastic cap that I'm fairly certain is what you need. PM me your details and I'll get it out to you.
      · 0 replies
  • Adverts

×