Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Guest

simplicity 4212

Recommended Posts

Guest
can somebody help.has 12 hp briggs ic.have rebuilt carb including float run a little then starts blowing black smoke an shuts down.Ican turn the high speed mixture screw in the whole way an it still runs rich.Have checked float level.Thanks arlen

Share this post


Link to post
Share on other sites
JonetteP
Hi Arlen, I would check the valve cover. If the plate inside the valve cover does not float easily, it will hang up an allow the engine to suck oil into the intake. If you notice a lot of oil in the carb inlet this is most likely the problem. Hope this helps. Neal Pierce

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • GregB
    • hurleyii
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 2 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×