Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Mine19821

Nova 2 ignition

Recommended Posts

Mine19821

Has anyone used this nova 2 system? How are you mounting them? I tried one on my 725 because i believed it had a condenser going bad and it fixed the issues. Also put one on my b10 that i believed had a carburetor problem at first and it ran better than it ever had. So far pretty impressed with them.

5425B123-982A-430B-A125-8105B5487044.png

Share this post


Link to post
Share on other sites
dhoadley

I have one on an ancient rototiller with a tiny (2-3hp) B&S. Wiring was dead simple except ... the spade connectors aren't reversible; they work one way but not the other. For that reason, I mounted mine on the outside tin. Works Great!

Share this post


Link to post
Share on other sites
landlord2110

I have 2 landlord2110's, one has the nova, the other doesn't-YET. It' the best thing I did, putting this on. I was constantly cleaning & adjusting points before nova2. I have  had no problems since installation in 2010. I had to adjust spark pug gap cause of spark knock. You'll never look back.

Share this post


Link to post
Share on other sites
Mine19821
43 minutes ago, landlord2110 said:

I have 2 landlord2110's, one has the nova, the other doesn't-YET. It' the best thing I did, putting this on. I was constantly cleaning & adjusting points before nova2. I have  had no problems since installation in 2010. I had to adjust spark pug gap cause of spark knock. You'll never look back.

What would you recommend for a gap?

Share this post


Link to post
Share on other sites
Richard Wright

I have used three of these on old Stihl chainsaws where you can't get points and condensers any longer. Absolutely no problems with the spark since installation. I would use them anytime I can.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
kwt

Two 10 horse Kohler K series, 1 10 horse, 1 12 horse and 1 16 horse cast iron Briggs. I guess I have 5 installed. Great product.

Share this post


Link to post
Share on other sites
fishnwiz
On 5/24/2018 at 7:29 PM, Richard Wright said:

I have used three of these on old Stihl chainsaws where you can't get points and condensers any longer. Absolutely no problems with the spark since installation. I would use them anytime I can.

 

Richard

You had room to mount these modules inside the original saw case without issue?  Did you need to remove any components? 

Share this post


Link to post
Share on other sites
Richard Wright

On big old chainsaws there's usually some room inside the case to mount them where the points used to be, but on a Stihl 015 there was no room in the case so I had to mount the unit on the outside and run the wire inside.  It still works fine.

  • Thanks 1

Share this post


Link to post
Share on other sites
gwiseman

My NovaII installed on a Bumblebee 10. Has its quirks but starts every time (battery is up) and fires like its supposed to. I have an ample supply of new points and condensers on the shelf as well but NovaII requires no adjustment.

  • Like 1

Share this post


Link to post
Share on other sites
Mine19821
7 minutes ago, PhanDad said:

 

MegaFire_Mounted2.thumb.jpg.cb254f5dfca0cb902bc99163dd821731.jpg

 

Haven’t figured out how yet. The one on my 725 i zip tied to the carburetor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×