Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

spi

governor issues

Recommended Posts

spi

I have a 12HP iron Briggs. After running an hour the governor stops working. Acts like something is sticking.  Anyone seen this before?

Share this post


Link to post
Share on other sites
fishnwiz

Just for the heck of it I think you should go to YouTube and watch a video of how to set a governor initially and try running the tractor through its paces again just to get an idea if anything changes. 

Share this post


Link to post
Share on other sites
spi

It will run just fine while mowing for about an hour. Then the governor stops working, engine still runs ok but it wont get extra throttle when it hits high grass or goes up a hill. Once in a while I need to push in the clutch to keep it running when it has a load.

Share this post


Link to post
Share on other sites
PhanDad
2 hours ago, BLT said:

I would also check for a blockage in the fuel line, starting with the fuel tank and working forward.

I agree; especially check the tank if the fuel out let screen was removed.  

I had an issue mowing on a hill - was definitely a fuel issue.  Drove me nuts until I finally removed the fuel tank and found a loose gooey deposit that would occasionally move to the tank outlet where it would restrict flow (no screen).  It never did that sitting level during testing for fuel flow.   

 

Share this post


Link to post
Share on other sites
spi

FOUND IT!

While fiddling with the carb. I saw that the plug on the end was laying on the ground. Well that explains it the plug was loose. I tapped the plug back to original shape and reinstalled it. while doing that I noticed the carb. was loose. tightened it up and the engine runs like a charm. Massive vacuum leak.

Thanks for the advise everyone

Share this post


Link to post
Share on other sites
dhoadley

I was wondering why I had to adjust the carb mixture lately, and then noticed to air cleaner vibrating while it was running. One of the carb mounting bolts went in 2 full turns! :o

Share this post


Link to post
Share on other sites
spi
9 hours ago, dhoadley said:

I was wondering why I had to adjust the carb mixture lately, and then noticed to air cleaner vibrating while it was running. One of the carb mounting bolts went in 2 full turns! :o

funny how the simplest little thing can make you scratch your head.

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×