Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
JeffN

Regent

Recommended Posts

JeffN
My dad has a Regent that is experiencing problems engaging the blades when hot. He says that if he stops and then starts and tries to engage the blades they will not go unless he lets the tractor cool down a bit. Any suggestions? Thanks.

Share this post


Link to post
Share on other sites
Al
Hi, If it has the electric clutch with the 3 adjustment bolts and springs. Set the clutch for .015 clearance in the openings and it will probably fix it. Any questions check the manual or yell like h___ and we will help you, Good luck, Al Eden

Share this post


Link to post
Share on other sites
JeffN
I found out the model # on my dad's tractor to see if that is any help. It is 1693080. It is a 14hp Hydro. If it is hot the blades will not engage. If you let it cool down it seems to work fine. I didn't see anything in the manual about adjustment of an electric clutch. Any other suggestions? Thanks.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • Bill725
    • BLT
    • GWGAllisfan
    • Al Truistic
    • SmilinSam
    • Brettw
    • GregB
  • Today's Birthdays

    1. wbakunis
      wbakunis
      (28 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 2 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×