Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Mine19821

64 landlord

Recommended Posts

Mine19821

Picked up a 64 landlord to go with my 64 broadmoor last night. Runs pretty well aside from the original coil is bad. I do have the light bar but no lights. Noticed the steering was pretty sloppy hopefully i can find steering gears or modify newer ones for it. Didn’t find the upper part of the grill but says he has it. Of course the common hood bolts are missing hahaha. Did come with a bolt together deck to. Didn’t think i did bad trading a newer saber rider for it.

90703EDA-C7D1-4EAA-8B12-95B40B61787A.jpeg

Share this post


Link to post
Share on other sites
Mine19821
8 hours ago, PhanDad said:

Nice trade.

And what's that white stuff on top?

 

It’s that nasty snow crap! So far i really like this 64. Hung a plow on it tonight. Tomorrow I’ll chain it and put the counter weight on! 

Share this post


Link to post
Share on other sites
PhanDad
14 hours ago, Mine19821 said:

It’s that nasty snow crap!

Tell me about it; got about 5" yesterday and I was unprepared.  Still have the leaf equipment mounted as the leaves have yet to all come down.  At least it's relatively warm today and the stuff should melt so I can suck up the remaining leaves this weekend.  

  • Like 1

Share this post


Link to post
Share on other sites
MrSteele

Can you post a pic of the light bar? I got a 64 earlier this year, will rebuild for my grandson to ride in parades util I can find some attachments. Mine not in running shape, ...yet

Share this post


Link to post
Share on other sites
Mine19821
4 minutes ago, MrSteele said:

Can you post a pic of the light bar? I got a 64 earlier this year, will rebuild for my grandson to ride in parades util I can find some attachments. Mine not in running shape, ...yet

I can dOd that a bit later when i get back out to the shop. 

Share this post


Link to post
Share on other sites
Mine19821
8 hours ago, MrSteele said:

Can you post a pic of the light bar? I got a 64 earlier this year, will rebuild for my grandson to ride in parades util I can find some attachments. Mine not in running shape, ...yet

It’s still attached but just a flat bar really. 

A1D4260C-F206-4573-BCB4-1D1D82B085E8.jpeg

Share this post


Link to post
Share on other sites
MrSteele

Thanks to both of you.I have never seen how the lights were attached. PO cut into my grille on the 65 I use, and put a set of 1967 GTO back up lights into the grille for headlights. I know it is wrong, but no one else around here does, so I left them in. Will have to buy perforated metal for the upper parts of both the 64 and 65 eventually, will probably have to buy enough to make the lowers as well, will work on that project when the time comes. Just getting ideas for when eventually gets here

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who's Online (See full list)

    • PGL
    • 9934059
  • Today's Birthdays

    1. cojo92
      cojo92
      (29 years old)
    2. Rebel_Ron
      Rebel_Ron
      (36 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 1 reply
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×