Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Ebailey

Legacy Hydro Issues

Recommended Posts

Ebailey

I am hoping someone here has some experience with the legacy hydro pump and can save me!  

I had a leak from the lip seal on the drive shaft for the hydro pump on my Legacy.  I replaced the seal, o ring,and bearing while I was in there.  After putting it back together the pump whines at high RPM and while turning the steering wheel.  I assumed it was possibly sucking air around one of those seals so I swapped them again after a couple mowings.  Unfortunately it still seems to be making the noise.  I did replace the fluid with fresh type F fluid and new filter.  

I am at the end of my rope with this thing since it was working fine before I swapped the leaking seal.

Share this post


Link to post
Share on other sites
RAC

Whining except for cold weather operation is usually air, over pressure or starving for fluid. Filter is on the suction side, what'd you use for a filter. I'm not a factory filter fanatic, but the suggested micron rating from Sauer Danfos isn't all that low. Use something with a really fine rating?

  • Like 1

Share this post


Link to post
Share on other sites
Ebailey

Forgot to try and turn the filter before I mowed yesterday, but the strange thing was that it seemed to be much quieter after it warmed up.  Went back after it sat for a while and it was whining again.  This would make sense on a cold day or if I put the wrong fluid in, but it was 80 deg out yesterday.

Share this post


Link to post
Share on other sites
SmilinSam
2 hours ago, Jim J said:

did you lift pin up on vent,(it is on a 90 next to the filter usually), hold up lightly with small vise grips then fill it, it will suck the fluid in 

I think you are thinking of a Soveriegn...

Share this post


Link to post
Share on other sites
Ebailey
2 hours ago, Jim J said:

did you lift pin up on vent,(it is on a 90 next to the filter usually), hold up lightly with small vise grips then fill it, it will suck the fluid in 

I don’t remember any vents on this one.  I will have to look tonight.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who's Online (See full list)

    • airgunner
    • GregB
    • 720nut
    • PhanDad
    • john jacob
    • ParkerBarker
    • TomSchmit
    • tadams
    • matthewmaddox153
    • plastikosmd
  • Today's Birthdays

    1. cojo92
      cojo92
      (29 years old)
    2. Rebel_Ron
      Rebel_Ron
      (36 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 1 reply
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×