Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Redbeard86

Transmission Filter

Recommended Posts

Redbeard86

I recently got my grandfathers Deutz allis 912 hydro up and running (today actually). It has been setting for over a decade in his garage. Anyway, I want to service it now that is running and need a number for the screw on hydraulic filter. All the paint is gone from mine and it isn’t listed in my service Manuel. If anyone has this info it would be greatly appreciated. Thanks in advance....

Share this post


Link to post
Share on other sites
Redbeard86

Its the one that mounts on the left, it a very "stubby" filter. Also, after initial start up the tractor wouldn't move in forward or reverse, but then just took off after idling a few minutes. It pulled great then quit pulling while riding it...so I pulled it down in neutral and then back to forward and it took off again.  I'm attributing to it setting so long an hope that a fluid and filter change will resolve that issue....Im reading dexron II or Type F in the trans, is that the best options?  also i checked the fluids in the BGB and Trans before trying it out and they were both full. the points were broken in a place very difficult to see without taking them off the engine so I'm thinking thats why the tractor was setting so long and not tranny issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×