Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

MTopp

Deutz-Allis 1613h mower deck question

Recommended Posts

MTopp

Hey all, had a quick question about my deck spindles. They seemed to have some play so I wanted to check out how the bearings/spindles looked.

According to the diagram, the washers have been installed incorrectly for years and theres some wear on the splines. Parts 4 and 5 on the diagram. 

Any opinions on this or what the right way to have them is?

20200406_145732.jpg

20200406_145737.jpg

Screenshot_20200406-145714_Quickoffice.jpg

Share this post


Link to post
Share on other sites
MTopp

Looks like the top pulley is gonna be a real pain to get off as well, maybe I'll let them soak with PB for a few days, using a torch would be last resort, but the puller was just starting to bend the pulley.

I really need to get a air hammer or bearing puller.

Share this post


Link to post
Share on other sites
PhanDad

See this post for everything you ever wanted to know about the "new" style arbors:

https://simpletractors.com/forums/topic/37879-spindle-repair-final-pictures-1690709-deck/

I'm thinking part #8 is the "collar" and you haven't have one installed.  The collar keeps the blade centered and since the area where the collar fits, the splines are ground so the other engagement splines aren't damaged.  

Pics and discussion are in the above post.  

 

  • Like 1

Share this post


Link to post
Share on other sites
MTopp
4 hours ago, PhanDad said:

See this post for everything you ever wanted to know about the "new" style arbors:

https://simpletractors.com/forums/topic/37879-spindle-repair-final-pictures-1690709-deck/

I'm thinking part #8 is the "collar" and you haven't have one installed.  The collar keeps the blade centered and since the area where the collar fits, the splines are ground so the other engagement splines aren't damaged.  

Pics and discussion are in the above post.  

 

Actually that collar is there, but its been squished by the washers. It almost looks like a C-clip, but it came off easily, so I think it may have broke when someone switched the washers around. Just checked, it's supposed to be split.

Read that thread and now I get what you're saying. 

And the #4 part is a "spring washer" which I think I have worn out. I'll be needing a few parts I suppose.

Edited by MTopp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×