Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

OrangeMetalGuy

712H - runs well but with choke partly closed

Recommended Posts

OrangeMetalGuy

My 712H runs well but only if I keep the choke about 1/3 closed (knob 1/3 pulled out) after it's warmed up.  Where do I start to troubleshoot this?  Thanks.

 

 

Edited by OrangeMetalGuy
sp

Share this post


Link to post
Share on other sites
PhanDad

Check for air leaks in carb to engine "piping"; could be loose bolts or missing gasket.  Spray ether (or carb cleaner) on joints and if the engine speeds up, you've found the problem area.  

If the piping tight, check the hi speed jet.  Maybe some debris in it.  With a Briggs, you can remove the whole needle assembly and let some gas run out to purge the debris.  I'm thinking your AC 712 has a Kohler and I don't know if you can do that.  

 

Edited by PhanDad
spelling

Share this post


Link to post
Share on other sites
MikeES

Beside what is mention above, with the Kohler a little debris in the fuel line right at the float needle will do the same thing.  Running partial choke helps pull the gas into the float.

Share this post


Link to post
Share on other sites
Jim J

does yours do this when it is used and engine is hot, I have a similar problem it stumbles and almost shuts off but when brought to idle it runs fine, mine is 7116 Briggs,it does seem to get the rpm at full throttle please help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×