Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Another KwikWay question


Hick

Recommended Posts

One the loader spool that has the detent (raise / lower), the cap on mine has two holes drilled in it. One looks like it may be original, the other looks like it was added. The drawing of the cap show no hole (but that could be the drawing). 

20210519_114027.thumb.jpg.e29f0bfab0e533500fb5ada1fe2cd9b2.jpg60a54126ba4f5_KwikWayvalve.JPG.832916542e7c7f83f65bf11c03532288.JPG
Those of you who have this loader, could you look at your cap and see if it has a hole?
The o-ring (other topic) is behind this cap and the fluid is leaking out of the holes.
The flange of the cap has been broken, welded, and broken again. I used JB Weld to fix it again. Would be better if I could find a replacement cap.

  • Like 1
Link to comment
Share on other sites

Gary I haven't ever had a KwikWay loader but I have had 5 Ark loaders.  On the detent (raise/lower/float) side like yours, the end cap is longer than the bucket roll/dump side.  Both caps on the Ark loaders have a hole in the center however it has a sintered bronze filter pressed in the hole.  I believe this is to alow condensation/moisture to evaporate.  If you are leaking oil out that hole, you have O-rings that are leaking past the valve into the cap.  The Ark's caps are threaded onto the spool & when removed, there is a spring & 2 detent balls that will go flying if you are not careful.

  • Like 1
Link to comment
Share on other sites

43 minutes ago, ShaunE said:

If you are leaking oil out that hole, you have O-rings that are leaking past the valve into the cap.  The Ark's caps are threaded onto the spool & when removed, there is a spring & 2 detent balls that will go flying if you are not careful.

Yes, that was the issue. Got a new o-ring and fixed it today. The reason I questioned the hole is because the other spool cap does not have one. It isn't a detent, but that shouldn't make any difference.

18 minutes ago, hurleyii said:

I have a kwikway and I don't recognize that part at all.

It is on the hydraulic control valves.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...