Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

simplicity 5211 1691065


stressed

Recommended Posts

My parents bought this tractor a few years ago from I don't know were. I just got it back to running shape were I derusted everything and painted and rebuilt engine. It now runs perfectly except for the transmission. I have 1 forward gear and 5 reverse gears!?!?!?! the pully for the transmission is currently facing up and the engine is a original 11hp brigs.

Can someone please help me figure out why. I can easily rebuild a engine but a transmission is new to me. 

Edited by stressed
Link to comment
Share on other sites

Maybe the drive belt is twisted wrong? :$

Welcome to the site and good luck. Others with some real knowledge should be chiming in soon. Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Who's Online (See full list)

    • PhanDad
    • Austinp6896Z
    • s_stephen
    • a_sannine
    • GregB
    • BLT
    • rolo
    • dhoadley
    • Patrick Kelly
  • Recent Status Updates

    • gwiseman

      gwiseman

      I am having ankle replacement surgery Monday 4/8 and will be away from ST business for a few days till the drugs clear out. Keep reviewing ST and let us know challenges and suggested revisions. gw
      · 2 replies
    • gwiseman

      gwiseman

      As you know SimpletrACtors.com has changed some recently. Working through this so PM me with questions, suggestions, and/or challenges you have. Appreciate your patience and feedback.
      · 0 replies
  • Adverts

×
×
  • Create New...