Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
jpw

i think she's gone

Recommended Posts

jpw
mowed for about 3 hours straight today 80-90 degrees had just finished and was heading back to trailer when the motor popped and alot of smoke rolled from under the hood. i shut her down and opened the hood it was very hot and the tube running from motor to bottom of air cleaner was on fire (KT17 II) blew it out and removed air cleaner assembly. after letting it cool for about half an hour it started and ran poorly it had just enough to get onto the trailer black smoke from the exhaust just before it quit. any thoughts on how bad she may be? thanks, joel

Share this post


Link to post
Share on other sites
Dutch
If it still runs that's a good sign. No holes in block? No oil running out? When's the last time you checked the fan, screen & shrouds for grass, mouse nests, etc.? Sounds like it was really hot. Start by removing the plugs and check compression. You may only have minor problems. Good luck.........

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • gwiseman
    • tadams
    • Mike8337
    • MrSteele
    • skot71
    • BLT
    • lugnard
    • BenB
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • F.U.N.

      F.U.N.  »  sandyhillbill

      Dear Sandhillbill
      Can you please copy me on this data, for Sun Star parts list.
      :
      September 12, 2004 Mike I sent you a PM and have all the mfgs. available for the tiller/hitch/pto/liftgroup if you need me to send them to you. Let me know. Thanks, F.U.N.    
      · 0 replies
    • gwiseman

      gwiseman

      Club banners are available  for members use during show season https://simpletractors.com/forums/topic/57849-simpletractors-club-banners-available/
       
      · 0 replies
  • Adverts

×