Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Smokin instrument panel


gwiseman

Recommended Posts

Couple days ago I needed to pull the truck into the shop. Easy enough right?  I pulled moved the mower tractor, the sovereign and trailer, and then went to the loader tractor (Agco 2025 / Legacy); wouldn't start!>:(  Jumped it from the pickup and started moving out of the shop. No sooner was I out into the yard when it coughed, died and a stinking smoke started filling the instrument panel. I unhooked the electrical connector plug from the back of the panel and removed battery.  Yesterday I installed a new 51r from Menards (cheapest 3yr battery in town), hooked up the instrument panel pulg and started the tractor. Immediately smoke inside the panel again so I grabbed the plug from the back of the panel and used the tractor. I suppose I have a short in the panel? Anyone have experience and a fixable solution? May just fly w/o instruments from now on. ..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...