Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Allis 917 with simplicity stickers


maxwood

Recommended Posts

Hello, I bought a 917 advertised as a simplicity it has an ID tag that says it is an allis 917  1690574

It started and drove on the trailer.  The PO said it was sluggish and would not lift the snowblower

The only thing I have done is remove snowblower and Tire chains It hast front and rear wheel weights.

Thanks Ken in Mi

IMG_4770.JPG

IMG_4769.JPG

IMG_4773.JPG

IMG_4772.JPG

  • Like 2
Link to comment
Share on other sites

Nice!  Simplicity or Allis, same tractor, different decals.  Sluggish may have a number of issues, by my bet is that it isn't the pump.  New filter and fluids, make sure the release valves are all the way up. belt to the pump is tight, etc.  Unless abused or dragged for a long distance, the Sundstrand pumps are, in my experience, pretty much bulletproof.

Link to comment
Share on other sites

Hello, The previous owner said That he changed the pump 3 yrs ago , 

I wonder if the pump has been shimmed, to provide the proper pressure ?

So who knows what has happened to this tractor over the past 40 years?

There is a tag on the engine ,That says  This KT engine was replaced with a Series II shortblock .

I'll spend more time on it next week .  Enjoy the big game !!

Thanks Ken in Mi

Edited by maxwood
  • Like 2
Link to comment
Share on other sites

I had a neighbor snow blow my driveway with my Sovereign while I was out of town. It was his first time. He told me it did not want to lift the blower. Found out he was not running the engine at full throttle/speed.

  • Like 2
Link to comment
Share on other sites

Hello, Today I put a fresh battery in the tractor it started right up.

I  drove it around for 10 minutes and went to shut it off . The key would not turn it off 

I pulled the sparkplug wires off to stop it.

While I was looking at it I realized it was missing an ignition coil and points cover

the sparkplug wires go into the housing , electronic ignition??

while driving it around the start stop of the hydro  was  jerky

Thanks Ken in Mi

IMG_4777.JPG

IMG_4778.JPG

  • Like 1
Link to comment
Share on other sites

If it was a magnum upgrade, they require a different key switch or some additional wiring to a separate toggle switch. At least the Magnum repower I have was wired like that. Central Power Distributors is or was the Kohler distributor & they are the ones that informed me about the key switches needing to be changed. To what? I don’t know.

Link to comment
Share on other sites

As far as the decals, the paint color is the tip off as it is all orange.  The Allis 912 I have is likewise all orange.  The Simplicity 7117 is partly orange but with a beige hood and black dash tower.  Other years might be different.  

Link to comment
Share on other sites

11 hours ago, ShaunE said:

Central Power Distributors is or was the Kohler distributor & they are the ones that informed me about the key switches needing to be changed. To what? I don’t know.

I would think the key switch would be a "Briggs" type since it's my understanding the Magnum has magneto ignition.  

18 hours ago, maxwood said:

The key would not turn it off 

Maybe the PO didn't change the ignition switch and didn't terminate the hot wire that went to the KT coil, the heavy black line in this diagram:  

image.png.be886eeca31322160252e1ad5d491521.png

 

This is a wiring diagram for a SunStar with Magnum engine of about the same vintage:

image.png.51cfc4fdd8ee2acb555296c22199f25b.png

Check out the engine connector plugs for the color of the wires hooked (or not) to them.  It could could provide some clues.  

 

Link to comment
Share on other sites

When I swapped the broke KT out of my 917H for a Magnum, I used a relay kit instead of purchasing a new switch and swapping that also.

 

Got it from Al Edens place at the time.

There was a diagram posted of the relay set-up to mimic the kit I bought.

 

I guess though you need to figure out what the swapper actually did using Bills info above.

  • Like 1
Link to comment
Share on other sites

19 minutes ago, GregB said:

There was a diagram posted of the relay set-up to mimic the kit I bought.

@BLT's relay diagram:

BLTRelayWiring.jpg.0c0725d4fa5313a6fd1452e73c444182.jpg

 

 

Link to comment
Share on other sites

Hello, I will check this out next week when the weather is warmer. 

The more I look at this the more I find, the drive shaft is missing the rubber donut, just 2 metal sleeves.

I am thinking of pulling the engine, to clean and sort the problems.

Thanks Ken in Mi

  • Like 3
Link to comment
Share on other sites

Hello, I was looking at the tractor and wondered about the front wheel weights ? 

it turns out that they are hubcaps part # 1714926

I have not seen these before.

Thanks Ke in Mi

IMG_4779.JPG

IMG_4780.JPG

  • Like 2
Link to comment
Share on other sites

46 minutes ago, maxwood said:

I have not seen these before.

Me neither, only baby moon hubcaps.  

 

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...