Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

I got a 920 delivered to me today


s_stephen

Recommended Posts

s_stephen

a tractor buddy brought me this 920 today that has been repowered with a 16hp briggs. it  hadent moved or ran in 15 years.20240427_174707.thumb.jpg.0e2f0abfe8e1b2092848dd78419a7d9a.jpg20240427_174716.thumb.jpg.dc6c8ce211c2bfc578bae391aefc24bc.jpg 20240427_175359.thumb.jpg.f61c39eff86d0040341b46802c0ae0e4.jpgi got it running and the engine runs good but the hydro leaks bad. good thing i have a few parts tractors sitting around to rob a hydro from. now i just need to find a original diesel engine for it and it will be put on the list for a restoration.

  • Like 5
Link to comment
Share on other sites

maxwood

Hello, where does it leak from?

I have had some leak from the short rubber tubing at the back of the tractor near the fill tube.

A few hose clamps should fix it , if that is where it leaks. 

Another thing to check is the hydro trans oil filter  which may be remote mounted under the tractor.

Hope this helps.

Thanks Ken in Mi.

 

Link to comment
Share on other sites

s_stephen
11 hours ago, maxwood said:

Hello, where does it leak from?

I have had some leak from the short rubber tubing at the back of the tractor near the fill tube.

A few hose clamps should fix it , if that is where it leaks. 

Another thing to check is the hydro trans oil filter  which may be remote mounted under the tractor.

Hope this helps.

Thanks Ken in Mi.

 

the hydro pump has a crack in it by where it mounts to the transaxle and wont build pressure. just runs the oil out of the crack

  • Sad 3
Link to comment
Share on other sites

×
×
  • Create New...