Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Guest

Simplicity 16 LTH won't go in reverse

Recommended Posts

Guest
Please Help! I have a 91 Simplicity that goes forward just fine, but suddenly quit going in reverse. I checked linkage and connections and all look fine. There is no noise or creeping when put into reverse. Forward acts normal. Thanks! Thanks

Share this post


Link to post
Share on other sites
arjr111
Hi Ted, I have a 16 GTH, gear drive, I'm assuming you have the hydro drive model, did you check the hydro level. A new filter may help too, if it has never been checked or changed.....Art

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • tamurmueen
    • smalljob
    • CarlH
    • Aussieskier
    • TTDE419
    • SmilinSam
    • PhanDad
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
    • thedaddycat

      thedaddycat  »  SmilinSam

      It's in pretty sad shape, but yes I have a yellow plastic cap that I'm fairly certain is what you need. PM me your details and I'll get it out to you.
      · 0 replies
  • Adverts

×