Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
ChuckinVa

AC RB-2430 Tiller help

Recommended Posts

ChuckinVa
I picked up a AC walk behind tiller today and would like to get pointed in the right direction for some sites that would give me some trouble shooting step by step instructions to get it running. There is not any spark at this point and after pulling the flywheel cover off of it and removing all of the junk accumulated there, I found a great deal of rust on the flywheel and the laminations on the coil looking thingy that goes to the spark plug ( technical talk ) are separating. I'm hoping there is a site that breaks down trouble shooting into sections so I can go over this engine ( B&S 5HP )one step at a time and hopefully be ready to till in a few weeks. ChuckinVA

Share this post


Link to post
Share on other sites
arjr111
Hi Chuck, can't point you to a step by step, but I have found the following sites, to be very useful. Good luck....Art [url]http://bbs.cartserver.com/bbs/a/5624/index.cgi[/url] [url]http://www.antiquetractors.com/garden.htm[/url] [u][http://www.antiquetractors.com/cgi-bin/aboards.cgi/u]

Share this post


Link to post
Share on other sites
ChuckinVa
Thanks Art. Looks like its going to be a challenge. I replaced the coil today thinking that might get the spark back but didn't do it. The coil was in pretty bad shape so probably needed to be changed any way. I'll need to get some info before I can proceed. Thanks for the links. ChuckinVA

Share this post


Link to post
Share on other sites
ChuckinVa
I did find this site which has a lot of information. I can't understand why the new coil doesn't fire. I have tried a different plug but to no avail. Nayone have any suggestions? http://www.repairfaq.org/sam/lmfaq.htm ChuckinVA

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×