Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Ron

Electric Clutch

Recommended Posts

Ron
I too have been having an electric clutch problem on my 1918 Deutz Ultima. Actually I had the problem last summer, it has been in the shed since then! When I flipped the switch to engage the mowing deck the clutch worked great. After the mower gets hot, if I shut off the deck, it doesn't want to re-engage. My guess is that gap settings are off. I probably won't work on it until this spring but just wanted to find out if my assumption might hold any water.

Share this post


Link to post
Share on other sites
Nubian
That would be the easiest/cheapest way to check it. When i first got my 1920 it did the exact same thing and that was exactly what was wrong with .18 usually works but try anyone between 15 and 20. I have 2 used extra field units part number 1679008 if you need to replace the clutch. I'm going to keep 1 spare for me the other i''l let go. Good luck

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Who's Online (See full list)

    • ShaunE
    • Aussieskier
    • TTDE419
    • SmilinSam
    • PhanDad
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
    • thedaddycat

      thedaddycat  »  SmilinSam

      It's in pretty sad shape, but yes I have a yellow plastic cap that I'm fairly certain is what you need. PM me your details and I'll get it out to you.
      · 0 replies
  • Adverts

×